package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)nodejs|(?i)starter-kit-nestjs|(?i)kafkaConsumerProducerBench`)
var str = `diagnostics-nodejs
documentdb-client-nodeJS
gherkin-runner-nodejs
openid-client-nodejs-useless
azure-blob-storage-client-nodejs
azure-sql-client-nodejs
CPNodeJS
appmon-oneagent-linux-nodejs-useless
kafkaConsumerProducerBench
sample-publish-kafka-nodeJS
starter-kit-nestjs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}