use strict;
my $str = 'diagnostics-nodejs
documentdb-client-nodeJS
gherkin-runner-nodejs
openid-client-nodejs-useless
azure-blob-storage-client-nodejs
azure-sql-client-nodejs
CPNodeJS
appmon-oneagent-linux-nodejs-useless
kafkaConsumerProducerBench
sample-publish-kafka-nodeJS
starter-kit-nestjs';
my $regex = qr/(?i)nodejs|(?i)starter-kit-nestjs|(?i)kafkaConsumerProducerBench/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}