$re = '/(?i)nodejs|(?i)starter-kit-nestjs|(?i)kafkaConsumerProducerBench/m';
$str = 'diagnostics-nodejs
documentdb-client-nodeJS
gherkin-runner-nodejs
openid-client-nodejs-useless
azure-blob-storage-client-nodejs
azure-sql-client-nodejs
CPNodeJS
appmon-oneagent-linux-nodejs-useless
kafkaConsumerProducerBench
sample-publish-kafka-nodeJS
starter-kit-nestjs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);