import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)nodejs|(?i)starter-kit-nestjs|(?i)kafkaConsumerProducerBench";
final String string = "diagnostics-nodejs\n"
+ "documentdb-client-nodeJS\n"
+ "gherkin-runner-nodejs\n"
+ "openid-client-nodejs-useless\n"
+ "azure-blob-storage-client-nodejs\n"
+ "azure-sql-client-nodejs\n"
+ "CPNodeJS\n"
+ "appmon-oneagent-linux-nodejs-useless\n"
+ "kafkaConsumerProducerBench\n"
+ "sample-publish-kafka-nodeJS\n"
+ "starter-kit-nestjs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}