import re
regex = re.compile(r"(?i)nodejs|(?i)starter-kit-nestjs|(?i)kafkaConsumerProducerBench", flags=re.MULTILINE)
test_str = ("diagnostics-nodejs\n"
"documentdb-client-nodeJS\n"
"gherkin-runner-nodejs\n"
"openid-client-nodejs-useless\n"
"azure-blob-storage-client-nodejs\n"
"azure-sql-client-nodejs\n"
"CPNodeJS\n"
"appmon-oneagent-linux-nodejs-useless\n"
"kafkaConsumerProducerBench\n"
"sample-publish-kafka-nodeJS\n"
"starter-kit-nestjs")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")