# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w{3}(?!$)/\g<0>./gm;t' <<< "A00
A000
A001
A009
A01
S92113
S92113D"