const regex = new RegExp('\\w{3}(?!$)', 'gm')
const str = `A00
A000
A001
A009
A01
S92113
S92113D`;
const subst = `\g<0>.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);