# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w{3}(?!$)"
test_str = ("A00\n"
"A000\n"
"A001\n"
"A009\n"
"A01\n"
"S92113\n"
"S92113D")
subst = "\\g<0>."
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.