#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\w{3}(?!$)"
Local $sString = "A00" & @CRLF & _
"A000" & @CRLF & _
"A001" & @CRLF & _
"A009" & @CRLF & _
"A01" & @CRLF & _
"S92113" & @CRLF & _
"S92113D"
Local $sSubst = "\g<0>."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)