using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w{3}(?!$)";
string substitution = @"\g<0>.";
string input = @"A00
A000
A001
A009
A01
S92113
S92113D";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}