import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w{3}(?!$)";
final String string = "A00\n"
+ "A000\n"
+ "A001\n"
+ "A009\n"
+ "A01\n"
+ "S92113\n"
+ "S92113D";
final String subst = "\\g<0>.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}