use strict;
my $str = 'A00
A000
A001
A009
A01
S92113
S92113D';
my $regex = qr/\w{3}(?!$)/mp;
my $subst = '\\g<0>.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";