re = /\w{3}(?!$)/m
str = 'A00
A000
A001
A009
A01
S92113
S92113D'
subst = '\\g<0>.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result