using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w]+.*\.[3mw][mp34ag].$";
string input = @"hdhdgd.mp3
sgsg.wma
fdfdfd hgg-dgdg.3gp
Emachichi-Hakuna Mungu kama wewe.mp3
gdgd gdfdf yddfr.mp3
tetete.txt
4f1c262493d4caf70d593226b3c73e00_direction.txt
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}