$re = '/[\w]+.*\.[3mw][mp34ag].$/m';
$str = 'hdhdgd.mp3
sgsg.wma
fdfdfd hgg-dgdg.3gp
Emachichi-Hakuna Mungu kama wewe.mp3
gdgd gdfdf yddfr.mp3
tetete.txt
4f1c262493d4caf70d593226b3c73e00_direction.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);