import Foundation
let pattern = #"[\w]+.*\.[3mw][mp34ag].$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
hdhdgd.mp3
sgsg.wma
fdfdfd hgg-dgdg.3gp
Emachichi-Hakuna Mungu kama wewe.mp3
gdgd gdfdf yddfr.mp3
tetete.txt
4f1c262493d4caf70d593226b3c73e00_direction.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)