# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\w]+.*\.[3mw][mp34ag].$"
test_str = ("hdhdgd.mp3\n"
"sgsg.wma\n\n"
"fdfdfd hgg-dgdg.3gp\n"
"Emachichi-Hakuna Mungu kama wewe.mp3\n\n"
"gdgd gdfdf yddfr.mp3\n"
"tetete.txt\n"
"4f1c262493d4caf70d593226b3c73e00_direction.txt\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.