import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w]+.*\\.[3mw][mp34ag].$";
final String string = "hdhdgd.mp3\n"
+ "sgsg.wma\n\n"
+ "fdfdfd hgg-dgdg.3gp\n"
+ "Emachichi-Hakuna Mungu kama wewe.mp3\n\n"
+ "gdgd gdfdf yddfr.mp3\n"
+ "tetete.txt\n"
+ "4f1c262493d4caf70d593226b3c73e00_direction.txt\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}