const regex = new RegExp('[\\w]+.*\\.[3mw][mp34ag].$', 'gm')
const str = `hdhdgd.mp3
sgsg.wma
fdfdfd hgg-dgdg.3gp
Emachichi-Hakuna Mungu kama wewe.mp3
gdgd gdfdf yddfr.mp3
tetete.txt
4f1c262493d4caf70d593226b3c73e00_direction.txt
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}