using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\d]+) (.*)";
string substitution = @"$2 $1";
string input = @"this is string 1 / 4w";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}