import re
regex = re.compile(r"([^\d]+) (.*)")
test_str = "this is string 1 / 4w"
subst = "$2 $1"
result = regex.sub(subst, test_str)
if result:
print(result)