const regex = /([^\d]+) (.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\d]+) (.*)', 'g')
const str = `this is string 1 / 4w`;
const subst = `$2 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);