use strict;
my $str = 'this is string 1 / 4w';
my $regex = qr/([^\d]+) (.*)/p;
my $subst = '$2 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";