#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=\s)\s+"
Local $sString = "Here is one space" & @CRLF & _
"Here are two whitespaces" & @CRLF & _
"Here are three whitespaces" & @CRLF & _
"Here are four whitespaces then three whitespaces" & @CRLF & _
" Four spaces at beginning preceded by a newline" & @CRLF & _
"Two spaces then three then four then five" & @CRLF & _
" then none" & @CRLF & _
"Four spaces at end " & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)