const regex = /(?<=\s)\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)\\s+', 'g')
const str = `Here is one space
Here are two whitespaces
Here are three whitespaces
Here are four whitespaces then three whitespaces
Four spaces at beginning preceded by a newline
Two spaces then three then four then five
then none
Four spaces at end
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);