import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)\\s+";
final String string = "Here is one space\n"
+ "Here are two whitespaces\n"
+ "Here are three whitespaces\n"
+ "Here are four whitespaces then three whitespaces\n"
+ " Four spaces at beginning preceded by a newline\n"
+ "Two spaces then three then four then five\n"
+ " then none\n"
+ "Four spaces at end \n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}