import re
regex = re.compile(r"(?<=\s)\s+")
test_str = ("Here is one space\n"
"Here are two whitespaces\n"
"Here are three whitespaces\n"
"Here are four whitespaces then three whitespaces\n"
" Four spaces at beginning preceded by a newline\n"
"Two spaces then three then four then five\n"
" then none\n"
"Four spaces at end \n")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)