re = /(?<=\s)\s+/
str = 'Here is one space
Here are two whitespaces
Here are three whitespaces
Here are four whitespaces then three whitespaces
Four spaces at beginning preceded by a newline
Two spaces then three then four then five
then none
Four spaces at end
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result