use strict;
my $str = 'Here is one space
Here are two whitespaces
Here are three whitespaces
Here are four whitespaces then three whitespaces
Four spaces at beginning preceded by a newline
Two spaces then three then four then five
then none
Four spaces at end
';
my $regex = qr/(?<=\s)\s+/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";