using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)\s+";
string substitution = @" ";
string input = @"Here is one space
Here are two whitespaces
Here are three whitespaces
Here are four whitespaces then three whitespaces
Four spaces at beginning preceded by a newline
Two spaces then three then four then five
then none
Four spaces at end
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}