package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)analystVerdictDescription\\\":\s+\\\"(?<analystVerdictDescription>[^\"]+)`)
var str = `\"mitigationStartedAt\": \"2022-04-13T03:57:58.393000Z\", \"status\": \"success\"}], \"threatInfo\": {\"analystVerdict\": \"false_positive\", \"analystVerdictDescription\": \"False positive\", \"automaticallyResolved\": false, \"browserType\": null, \"certificateId\": \"\", \"classification\": \"Malware\",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}