use strict;
my $str = '\\"mitigationStartedAt\\": \\"2022-04-13T03:57:58.393000Z\\", \\"status\\": \\"success\\"}], \\"threatInfo\\": {\\"analystVerdict\\": \\"false_positive\\", \\"analystVerdictDescription\\": \\"False positive\\", \\"automaticallyResolved\\": false, \\"browserType\\": null, \\"certificateId\\": \\"\\", \\"classification\\": \\"Malware\\",';
my $regex = qr/analystVerdictDescription\\\":\s+\\\"(?<analystVerdictDescription>[^\"]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}