import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "analystVerdictDescription\\\\\\\":\\s+\\\\\\\"(?<analystVerdictDescription>[^\\\"]+)";
final String string = "\\\"mitigationStartedAt\\\": \\\"2022-04-13T03:57:58.393000Z\\\", \\\"status\\\": \\\"success\\\"}], \\\"threatInfo\\\": {\\\"analystVerdict\\\": \\\"false_positive\\\", \\\"analystVerdictDescription\\\": \\\"False positive\\\", \\\"automaticallyResolved\\\": false, \\\"browserType\\\": null, \\\"certificateId\\\": \\\"\\\", \\\"classification\\\": \\\"Malware\\\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}