const regex = /analystVerdictDescription\\\":\s+\\\"(?<analystVerdictDescription>[^\"]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('analystVerdictDescription\\\\\\":\\s+\\\\\\"(?<analystVerdictDescription>[^\\"]+)', 'gm')
const str = `\\"mitigationStartedAt\\": \\"2022-04-13T03:57:58.393000Z\\", \\"status\\": \\"success\\"}], \\"threatInfo\\": {\\"analystVerdict\\": \\"false_positive\\", \\"analystVerdictDescription\\": \\"False positive\\", \\"automaticallyResolved\\": false, \\"browserType\\": null, \\"certificateId\\": \\"\\", \\"classification\\": \\"Malware\\",`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}