// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)analystVerdictDescription\\\":\s+\\\"(?<analystVerdictDescription>[^\"]+)"#).unwrap();
let string = "\\\"mitigationStartedAt\\\": \\\"2022-04-13T03:57:58.393000Z\\\", \\\"status\\\": \\\"success\\\"}], \\\"threatInfo\\\": {\\\"analystVerdict\\\": \\\"false_positive\\\", \\\"analystVerdictDescription\\\": \\\"False positive\\\", \\\"automaticallyResolved\\\": false, \\\"browserType\\\": null, \\\"certificateId\\\": \\\"\\\", \\\"classification\\\": \\\"Malware\\\",";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}