#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/(github\.com|meet\.jit\.si|example\.com|example\.net)|.*confluence.*"
Local $sString = "https://github.com" & @CRLF & _
"https://meet.jit.si" & @CRLF & _
"https://example.com" & @CRLF & _
"https://example.net" & @CRLF & _
"https://blah.confluence.blah.tld" & @CRLF & _
"https://anything.else.does.not.match" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")