$re = '/https:\/\/(github\.com|meet\.jit\.si|example\.com|example\.net)|.*confluence.*/m';
$str = 'https://github.com
https://meet.jit.si
https://example.com
https://example.net
https://blah.confluence.blah.tld
https://anything.else.does.not.match
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);