package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/(github\.com|meet\.jit\.si|example\.com|example\.net)|.*confluence.*`)
var str = `https://github.com
https://meet.jit.si
https://example.com
https://example.net
https://blah.confluence.blah.tld
https://anything.else.does.not.match
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}