re = /https:\/\/(github\.com|meet\.jit\.si|example\.com|example\.net)|.*confluence.*/m
str = 'https://github.com
https://meet.jit.si
https://example.com
https://example.net
https://blah.confluence.blah.tld
https://anything.else.does.not.match
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end