const regex = /https:\/\/(github\.com|meet\.jit\.si|example\.com|example\.net)|.*confluence.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/(github\\.com|meet\\.jit\\.si|example\\.com|example\\.net)|.*confluence.*', 'gm')
const str = `https://github.com
https://meet.jit.si
https://example.com
https://example.net
https://blah.confluence.blah.tld
https://anything.else.does.not.match
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}