// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/(github\.com|meet\.jit\.si|example\.com|example\.net)|.*confluence.*").unwrap();
let string = "https://github.com
https://meet.jit.si
https://example.com
https://example.net
https://blah.confluence.blah.tld
https://anything.else.does.not.match
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}