import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(github\\.com|meet\\.jit\\.si|example\\.com|example\\.net)|.*confluence.*";
final String string = "https://github.com\n"
+ "https://meet.jit.si\n"
+ "https://example.com\n"
+ "https://example.net\n"
+ "https://blah.confluence.blah.tld\n"
+ "https://anything.else.does.not.match\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}