#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(StartOrder,(\d{0,}).*?deliver.)"
Local $sString = "StartOrder,1,SupplierName," & @CRLF & _
"zzzzzzzzzz" & @CRLF & _
"EndOrder,5,booked as soon as possible to deliver1." & @CRLF & _
"StartOrder,6,SupplierName," & @CRLF & _
"aaaaaaaaaa" & @CRLF & _
"EndOrder,10,booked as soon as possible to deliver."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")