package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(StartOrder,(\d{0,}).*?deliver.)`)
var str = `StartOrder,1,SupplierName,
zzzzzzzzzz
EndOrder,5,booked as soon as possible to deliver1.
StartOrder,6,SupplierName,
aaaaaaaaaa
EndOrder,10,booked as soon as possible to deliver.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}