$re = '/(StartOrder,(\d{0,}).*?deliver.)/ms';
$str = 'StartOrder,1,SupplierName,
zzzzzzzzzz
EndOrder,5,booked as soon as possible to deliver1.
StartOrder,6,SupplierName,
aaaaaaaaaa
EndOrder,10,booked as soon as possible to deliver.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);