import re
regex = re.compile(r"(StartOrder,(\d{0,}).*?deliver.)", flags=re.MULTILINE | re.DOTALL)
test_str = ("StartOrder,1,SupplierName,\n"
"zzzzzzzzzz\n"
"EndOrder,5,booked as soon as possible to deliver1.\n"
"StartOrder,6,SupplierName,\n"
"aaaaaaaaaa\n"
"EndOrder,10,booked as soon as possible to deliver.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")