using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(StartOrder,(\d{0,}).*?deliver.)";
string input = @"StartOrder,1,SupplierName,
zzzzzzzzzz
EndOrder,5,booked as soon as possible to deliver1.
StartOrder,6,SupplierName,
aaaaaaaaaa
EndOrder,10,booked as soon as possible to deliver.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}