const regex = /(StartOrder,(\d{0,}).*?deliver.)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(StartOrder,(\\d{0,}).*?deliver.)', 'gms')
const str = `StartOrder,1,SupplierName,
zzzzzzzzzz
EndOrder,5,booked as soon as possible to deliver1.
StartOrder,6,SupplierName,
aaaaaaaaaa
EndOrder,10,booked as soon as possible to deliver.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}