# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/€\D*(\d+)[^<]*/$1/g;t' <<< "<span class=\"price\" id=\"old-price-3\">€ 200,00 </span>
<span class=\"price\" id=\"product-price-3\">€ 80,00</span>"