// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"€\D*(\d+)[^<]*").unwrap();
let string = "<span class=\"price\" id=\"old-price-3\">€ 200,00 </span>
<span class=\"price\" id=\"product-price-3\">€ 80,00</span>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}